Assets folders and explorer folders


#1

Perhaps I am just going about this wrong, but when I add a folder to the Assets in game studio, it is not automatically created in the explorer. I have to manually create them in the explorer in order to get the right folder layout synced. This goes for the beta 3.1.0.1-beta as well 3.0

Trying to open a newly made folder results in: “There was a problem starting the file explorer.”. Anybody else have this too?


#2

Empty folders might be lazily created until they contain something. Does it still happen if you add something (like a new asset) into it?

Note that git (and also to some extent Visual Studio) have the same behavior: empty folders are ignored.


#3

Thanks for the reply (both here and on discord).
I have to admit that I didn’t think of lazy loading. I will have to try it tonight.

This my regular workflow: when I start a new project, I just drag in a bunch of default folders to the assets folder (via the explorer), but those will never be visible in Game studio, since all assets are made using game studio and thus the folders remain empty.


#4

Yes, unfortunately, empty folders are ignored. And they appear in the list only after loading something in them and restarting the project.
They are created along this path:
Documents\Xenko Projects\MyGame\MyGame\Assets\Shared
Creating a tree of folders for specific needs and leaving them empty is equivalent to creating a zero!

Apparently the engine is self-clearing, as he believes - “from garbage”, that is, “it does not bother itself with empty hopes” :slight_smile:


#5

I guess it is something I have to live with, although I wonder how many people run in to this expecting the folders to sync directly.