Directional Light but no shadows


#1

I got a scene with an ambient light, a directional light and about 100 entities enabled shadows.
also ground-plane.
The light itself work imo perfectly fine, but there are no shadows. also if I turn on debugging I can’t see output of that in the scene editor.

really don’t have a clue anymore what I could be doing wrong.

any pointing in “another” direction is highly appreciated

Martin


#2

Hi!

Is the directional light placed inside a model?

Or there is a document about lights don’t cast shadows.

https://doc.xenko.com/latest/en/manual/troubleshooting/lights-dont-cast-shadows.html


#3

Hi @EternalTamago

Nope, the light is not in a model, and I know the document. I am pretty sure the atlas is big enough, since I only have one directional light (in addition to my ambient) and the size is /8.
And as I said, there are may 80-100 entities with simple models like sphere and box.

The “shading” on the models itself looks fine, but no shadows.

~m


#4

Sorry, I confused directional lights with spot lights.:scream:

“Cast Shadows?”(IsShadowCaster) property exists in both ModelComponent and ModelAsset.
To cast shadows needs to enable these properties.
That’s all I can come up with now.


#5

in both ModelComponent and ModelAsset

I suspect something like that, but in the editor I only find the enable shadow setting for the model to the entity.

(Head scratch)

Martin


#6

I used one of the template projects to get started.

Can it be that my Graphics Compositor is “so” messed up…

On the other hand. I did not touch this one up to now and now only for investigation for my issue…


#7

It’s got to do with SIZE/RADIUS and SCALE?

Can anyone refer me to stuff where this is explained? How do size and scale work together?

I kept size mostly one and scaled up to my measurements. This is working fine for the models, but not for lighting… (so far haven’t noticed any other side effects)

Thx,
~m