Error on new project (v2.1.0.3)


#1

Hi! After installation of version 2.1.0.3 i can’t compile any new, neither old project. Version 2.0.4.1 is working properly.
What can i do to workaround this error?
Check attached GameStudio log:

Verbose: Loading Assets from Package [Xenko.xkpkg]
Verbose: Loading Assets from Package [MyGame.xkpkg]
Verbose: Generating MyGame.Game…
Verbose: Generating MyGame.Windows…
Verbose: Loading Assets from Package [MyGame.xkpkg]
Verbose: Compiling game assemblies…
Verbose: Restoring packages for D:\PARADOX_PROJECTS\MyGame\MyGame\MyGame.Game\project.json…
Verbose: Committing restore…
Verbose: Writing lock file to disk. Path: D:\PARADOX_PROJECTS\MyGame\MyGame\MyGame.Game\project.lock.json
Verbose: D:\PARADOX_PROJECTS\MyGame\MyGame\MyGame.Game\project.json
Verbose: Restore completed in 1602ms.
Verbose: NuGet Config files used:
Verbose: C:\Users\Raimis\AppData\Roaming\NuGet\NuGet.Config
Verbose: C:\ProgramData\nuget\Config\Microsoft.VisualStudio.Offline.config
Verbose: Feeds used:
Verbose: https://www.nuget.org/api/v2/
Verbose: C:\Program Files (x86)\Microsoft SDKs\NuGetPackages
[D:\Silicon Studio\Xenko\GamePackages\Xenko.2.1.0.3\Targets\Xenko.targets(184,5)]: Error: The “AssemblyProcessorTask” task could not be loaded from the assembly D:\Silicon Studio\Xenko\GamePackages\Xenko.2.1.0.3\deps\AssemblyProcessor\SiliconStudio.AssemblyProcessor.Packed.exe. Could not load file or assembly ‘file:///D:\Silicon Studio\Xenko\GamePackages\Xenko.2.1.0.3\deps\AssemblyProcessor\SiliconStudio.AssemblyProcessor.Packed.exe’ or one of its dependencies. The system cannot find the file specified. Confirm that the declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask.
Error: Unable to build assembly reference [D:\PARADOX_PROJECTS\MyGame\MyGame\Bin\Windows\Debug\MyGame.Game.dll]
Verbose: Game assemblies compiled…
Warning: Can’t load Game assembly
Verbose: Compiling game assemblies…
Verbose: Game assemblies compiled…
Verbose: Restoring NuGet packages…
Verbose: Restoring packages for D:\PARADOX_PROJECTS\MyGame\MyGame\MyGame.Windows\project.json…
Verbose: Committing restore…
Verbose: Writing lock file to disk. Path: D:\PARADOX_PROJECTS\MyGame\MyGame\MyGame.Windows\project.lock.json
Verbose: D:\PARADOX_PROJECTS\MyGame\MyGame\MyGame.Windows\project.json
Verbose: Restore completed in 1400ms.
Verbose: NuGet Config files used:
Verbose: C:\Users\Raimis\AppData\Roaming\NuGet\NuGet.Config
Verbose: C:\ProgramData\nuget\Config\Microsoft.VisualStudio.Offline.config
Verbose: Feeds used:
Verbose: https://www.nuget.org/api/v2/
Verbose: C:\Program Files (x86)\Microsoft SDKs\NuGetPackages\


#2

No such file : “SiliconStudio.AssemblyProcessor.Packed.exe”. I replaced Xenko.targets file from version 2.0.4.1. Now it’s working properly.


#3

Thank you for figuring out a solution.