Error : Upgrading to 3.1 [ SOLVED ]

#1

I encountered some error while upgrading to 3.1, any tip to solve this ?

0 Likes

#2

Did a Visual Studio Installer starts? And if so did you cancel it (or close it)?

If you try again, do you get the same error?

0 Likes

#3

Hello Kryptos,

It’s asked to install a prerequiite for visual studio and accept it, after that image
below will follows, I tried it again but still failed.

Thanks

0 Likes

#4

Ok. There should be some logs somewhere that would tell us what went wrong.
@xen2 any ideas where they are located?

0 Likes

#5

I had a similar issue and it was because the VS Installer needs to be updated.

I investigated but sadly there is no command line option to make it self-update.
The only way is to embed the installer itself, but the problem is there is many variant of it (2017 Community, Pro, etc. and 2019).

Please just run the Visual Studio Installer from start menu.

I will try to make this message more clear, such as “It might be due because your Visual Studio Installer is out of date. Please run it manually and make sure it is up to date”.

0 Likes

#6

I investigated but sadly there is no command line option to make it self-update.

Seems like something worth reporting.

0 Likes

#7

FYI, I could confirm it was something not supported using those two links:
https://developercommunity.visualstudio.com/content/problem/307261/unattend-self-update-of-vs-installer.html
https://developercommunity.visualstudio.com/content/problem/193597/automated-update-of-visual-studio-does-not-work.html

0 Likes

#8

The fact that they close such issues without solving them doesn’t help.

0 Likes

#9

I will try to update my VS Community 2017 to version 15.9.10 and see if it solved the problem, thanks all for your input.

0 Likes

#10

Upgrading my VS Community 2017 installer to version 15.9.10 SOLVED the problem ^_^y

Thanks all!

0 Likes