None of the templates work Help!


#1

I previously had and install of xenko about 4 or 5 months ago installed on my computer and the templates worked fine. But after I updated to the current version in that install, the template didn’t work for it. But the other installs versions that I had on xenko about 4 or 5 months before still worked I think it was 2.1. So today I uninstalled xenko completely from my computer and reinstalled it. And xenko not only dose not work with 3.1 install version but non of them. So Basically all the templates fail to build when I create a project on all versions.

here is a pastabin of the entire error.
link: https://pastebin.com/0hkhWMJm

Any help I would be really grate full.


#2

did you install the visual studio build tools that the xenko launcher wants to install? also, do you have visual studio 2017 installed?


#3

Hi, I had a similar problem. The compiler couldn’t find Microsoft.NET.Sdk.

My solution was (some steps might have been unnecessary)

  1. Go to https://www.microsoft.com/net/download and installing Netcore 2.1 (both for x64 and x86)
  2. Go to https://www.microsoft.com/net/download/archives and installing NET Framework 4.6.1
  3. Adding an environment variable MSBuildSDKsPath to be C:\Program Files\dotnet\sdk\2.1.402\Sdks
  4. Running Xenko as administrator and then Reinstall the Visual Studio plugin
  5. Restarting windows

After that I was able to build using Xenko.


#4

This fixed the issue thank you.


#5

Glad to hear it helped.:slight_smile:


#6

What you describe is basically getting and installing the correct tools from Visual Studio 2017 installer. No need to do any of it manually.


#7

Curious, could you give me some additional info to try to fix this one once and for all?

  • What is your OS?
  • When it was broken, did you have Visual Studio installed already?
  • During Xenko install, did it ask you to install something related to Visual Studio or MS Build Tools?

#8

@Kryptos.
Ok, I didn’t know that. How do you do it from inside the installer?


#9

In VS go to: Tools -> Get Tools and Features
image
Then “Individual components tab”
image


#10

I’m using windows 10 vse 2017 and it was already installed. What fixed it for me was installing the x86 Netcore 2.1. The other x64 was already installed. I ran the visual studio installer in the launcher and it installed successfully, and It began to work properly. Thank You.