[SOLVED] Can't Target NET Standard 1.6 - Default Game/Xenko Interop


#1

Hey guys,

Lately I’ve been running with the project’s default NET Standard 1.4 target and have had some good learning success with the engine. I’m probably going to be a paid customer. I’d like to take advantage of some libraries for 1.6+ on NuGet. When I create a default game and then open it and target 1.6, the game will never run–I get a Application is in Debug error. I freshly installed VS2017 and Xenko to clear out any fudge factor and still no dice.

Is there a way to get around this? Can I change the target or hack something in Xenko?

If not, I’m having problems finding a copy of Lidgren.Network that will work with the default NET Standard 1.4 project build. I’m a hardcore Network Engineer and MP code is really what I’m looking to work with. Exploring alternatives.

Thanks,
-Jarmo


#2

Got this working.

Couldn’t tell you exactly what it was. This is what I did to resolve:

  1. Reinstalled VS.
  2. Reinstalled Xenko.
  3. Created Project.
  4. Changed project.json to point to “netstandard1.6” framework.
  5. Added a code library (my wrapper) same thing “netstandard 1.6”
  6. Ran NuGet Restore.
  7. Installed the libraries from NuGet that I wanted.

I may had to modify the csproj in there too to resolve some warnings.


#3

What kind of manual modifications did you need to do? Or was it specifric to your project?