Visual Studio Updates Breaking Xenko


#1

Howdy guys,

I’m not sure exactly what is happening, but here is the overview:

I install VS2017 fresh. I installed 15.3 and the latest version of Xenko 2.1.0.3 (not sure on this version number)… I’m able to work on Xenko projects for a day or so, and then the following day when I boot my workstation I launch the projects and they fail with: "The tools version “15.0” is unrecognized. Available tools versions are “2.0”, “3.5”, “4.0”. My VS does did not update. I’ve read around on the forums and it seems this is an incompatibility with 15.3 that was fixed in the latest version of Xenko?

I’d like to be a paid customer but I’m losing about 3-4 Hrs+ a day due to this issue and my personal schedule is slipping. What is the most sound advice for addressing this scenario?

Thanks in advance,
Jarmo


#2

So this happened again tonight at exactly 2 AM. I was able to get a couple hours of coding in before as I re-installed VS2017 on the latest version. At 2, same thing, error about MSBuild tools version. This time though I modified the .csproj files to state version 4.0 vs 14.0 (mine did not say 15.0). I got this from an online article… at that point I had some other lock on an index file so I rebooted. Appears to be solved. One other note is that the Xenko router had ran itself several times and was visible in the systray the past two nights this has happened.

I will monitor and if it works I’ll grab a link to the article and mark this solved.


#3

Appears to be fixed. The change I did namely was modify the csproj files to reference version 4.0 of MSBuild tools. Not sure where the 15.0 came from, and it would only happen after running for about a day, occurring at 2 AM.